Welcome to the new AusCraft website!
IP Copied!
Click to Copy IP
play.auscraft.net

[Guide] [1.16.2 +] Modding your client

Qty

Server Moderator
956


Introduction
AusCraft allows the use of certain mods to adjust / improve your gameplay experience. As a general rule of thumb, if a mod gives you an unfair advantage, then it's not allowed. However, please refer to the mod rules before installing any mods, or ask a staff member if you're unsure.

This guide will show you how to use Fabric Mod Loader to install mods. The guide was written based on 1.16.2, however, as long as Fabric continues to be updated, this guide will work regardless of Minecraft's current version. Whenever I refer to "the correct / relevant version", this may not be the LATEST version of Minecraft. Refer to the "Correct Mod / Client Version" in the Background Knowledge section to determine which specific version this is for you.

I know that the Background Knowledge section is a very large wall of text, however, it's important to understand these things before installing mods. Please take the time to read this, because once you understand these things, the actual process of installing mods will be easy peasy.


Contents
You can use Ctrl+F and search to navigate this forum post.
  1. Background Knowledge
    1. Preview vs Release Mods
    2. Fabric vs Forge
    3. Correct Mod / Client Version
  2. Allowed Mods
    1. Recommended Mods
  3. Installing Fabric Loader
  4. Installing Fabric API & Mods
    1. Navigating to .minecraft folder
Background Knowledge
Preview vs Release Mods

When new version of Minecraft are released, mods can take a while to create an updated version of their mods that are compatible with the latest version of Minecraft. However, the developers usually release versions of their mod that aren't fully stable, these are commonly referred to as: "snapshots", "previews", "beta" versions. They are less stable, however, they allow earlier access to the mod with the caveat that there may be bugs to iron out.

If a mod does not have a full release version for the Minecraft version you need, you can still install the preview version and then update to the full version once they release it.


Fabric vs Forge
Fabric and Forge are both Mod Loaders that will work in 1.16.2 and most likely also for future versions of Minecraft for the indefinite future.

Some mods may not be compatible with Fabric, and some may not be compatible with Forge. Thus, if any mods you really want to use are only compatible in Forge, then your decision is made on which loader to use. However, this guide is for Fabric only as most mods are compatible with it. The partial exception is Optifine, which is not natively compatible with Fabric, however, there is an additional mod that can be downloaded (OptiFabric) which allows Optifine to be compatible with Fabric. As long as OptiFabric is maintained, then Optifine will be compatible with Fabric.

Aside from mod compatibility, I personally prefer Fabric as it tends to load much quicker, and is generally updated to the new versions of Minecraft quicker.


Correct Mod / Client Version
This section will explain how to determine what version your mods and client should be, in order to function correctly on AusCraft. You'll need to know this before you start downloading mods, so that you can download the correct version of the mods.

The vast majority of the time, the server will be updated to the latest full release of Minecraft. However, this is not always the case. If there is a big new update that recently dropped for Minecraft, it may take some time for the server software and plugins that AusCraft relies on, to update to the correct version. Updating plugins and server software to the latest versions of Minecraft is a time consuming process that most of the relevant developers are doing for free. Thus, it is important to be patient after an update, that the server may not update straight away, whilst the developers of the software and plugins are updating everything and ironing out bugs.


GENERAL RULE OF THUMB: The version of your client must be compatible with the server version. The version of the mods installed on your client must IDENTICALLY match the version of your client.

Note that the minor versions are important. If you attempt to use a 1.16.1 or 1.16.3 mod with a 1.16.2 client, it will not launch, it will crash with an error. However, there is some more lenience when it comes to the server version. The server version will usually be FORWARD compatible, pay attention to #change-logs in Discord, where it will be announced what client versions are supported on the server, however, typically if the server is running a version (i.e. 1.15.2), then any clients on that version or newer versions will work (i.e. 1.15.2 - 1.16.2 and onwards). The server may at some stages support older client versions, however, using an older client version is not recommended.

Thus, check what version AusCraft is currently running (as at 08-Sep-20 it is running 1.16.2, which is the latest version, meaning 1.16.2 clients and mods are recommended, however anything 1.16 will probably work), and from there you can determine what version your client and mods need to be.


Allowed Mods

For clarification on what mods are allowed on AusCraft, please read this forum post.

Recommended Mods
The following mods are ones that I use or are known to be good mods. They will work with Fabric, and possibly Forge (but I haven't checked). Feel free to suggest mods for me to add to this list.
  • Optifine (OptiFabric required for Optifine to work with Fabric) - Optimises your game, improves FPS and allows more customisation of graphics settings.
  • lithium - This mod is a general purpose optimisation mod. Can be used as an alternative to Optifine.
  • VoxelMap - This is a minimap mod.
  • Giselbaer's Durability Viewer - Shows the durability of your items and armour in a visually friendly way.
  • Hwyla - Provides information about the block you're looking at.
  • light-overlay - F4 toggles showing the light level numbers on the ground, to help with setting up mob grinders and stuff.
  • modmenu - Allows you to view all installed mods, and configure them.
  • MyBrightness - No full release for 1.16.2, haven't tested the prerelease. May or may not work. This work allows more control of Brightness.
  • phosphor - NOT UPDATED - Not yet updated to 1.16.2. This mod optimises lighting performance.
Installing Fabric Loader
Head to https://fabricmc.net/, and click the download link for the Fabric Loader.
1161


You'll get an option to download either .jar or .exe. Do whatever you're most familiar with. Once the file is downloaded, double click it.
1162


In the GUI, select the relevant Minecraft Version, leave the Loader Version as default. Click Install once you're happy with the selections.
1163


Once this is done, you should now see the relevant Fabric version in your Minecraft launcher:
1164


Installing Fabric API & Mods
The method used to install Fabric API & Mods are almost always indentical, but different to installing Fabric Loader.

Note that Fabric API and Fabric Loader are two different things. Fabric API is not necessarily compulsory to add, however, many mods do require it, so it is wise to add it.

With Fabric Loader download, we were able to run the downloaded file. However, with mods and Fabric API, we need to find the right version .jar file and save it in our .minecraft folder.


Navigating to .minecraft folder
To find your .minecraft folder, open the Windows Run dialog, by typing "run" into the start menu.
1165


In the Windows Run dialog, type %AppData% and click OK.
1166


This will open the Roaming folder, which should have .minecraft in it. Open that up. Within the .minecraft folder, if you don't already have a mods folder, create one.


Find and install relevant Mod .jar file
Now, all you need to do is find the correct version of the Fabric API and relevant mods, and drop the .jar file in your mods folder.

For Fabric API, navigate to https://fabricmc.net/use/ and click the link for the Fabric API.
1167


On this curseforge page, don't just click Download, as it may be the wrong version, instead click Files tab.
1168


In this case, the Main file is the correct one for me, as it is the correct version (1.16.2), it is for Fabric and it is the latest build. Make sure not to download the Forge version of the mods.
1169


The same installation process now applies to all other mods. Find the latest Release build of the correct Minecraft version for the mods you want.


Optifine Note
Note also for Optifine, that you need to install OptiFabric for it to work.

Not Working / Questions?
Contact me if you have any questions / it's not working for you.
 
Last edited:

Qty

Server Moderator
By "now allowable" did you mean to say "not allowed"? Just checking cause that sentence is a bit confusing.
Thanks for making me aware of that. I've updated that and a few other things on the post. Hope it makes more sense now.